Tutorial Übersicht Tutorial Übersicht  >>  PHP Fusion PHP Fusion

PHPF 7.02 Falsches Adminrecht für Sicherheitseinstellungen
Von: Harlekin am: 23.10.2017 - 08:14 Gelesen 452 x gelesen drucken

Werbung:
ALL INKL



Heute ist mir aufgefallen, dass in der administraton/settings_security.php ein falsches Recht abgefragt wird.

Abgefragt wird S9, das müsste aber S12 sein. Beheben könnt ihr das wie folgt:

1. Öffnet die administraton/settings_security.php
2. sucht nach:
Code Alles auswählen
if (!checkrights("S9") || !defined("iAUTH") || !isset($_GET['aid']) || $_GET['aid'] != iAUTH) { redirect("../index.php"); }


ersetzt diese Zeile mit:
Code Alles auswählen
if (!checkrights("S12") || !defined("iAUTH") || !isset($_GET['aid']) || $_GET['aid'] != iAUTH) { redirect("../index.php"); }


Nun sollten auch Administratoren mit den im Adminbereich gesetzten Rechten da drauf zugreifen können.

War dieses Tutorial hilfreich für dich?
Nur Mitglieder können abstimmen!
Für 5 der Mitglieder war es hilfreich.
Für 0 der Mitglieder nicht.